前言

​ 安装最新版2021kali,安装成功后在vmware里安装vmtools,失败,在PD虚拟机内安装pdtools,失败,崩溃~~~~

查询资料说是内核太高问题,不兼容。也不知道是不是软件问题,还是什么。放弃了,自己打造自己的渗透环境

替换源

1、在ubuntu20中添加kali源,kali里还是有一些好用的工具,sqlmap,nmap,MSF等

2、在apt中配置kali源

vim /etc/apt/sources.list  //进入编辑

3、在文件底部添加以下配置

deb http://mirrors.cloud.tencent.com/kali/ kali-rolling main contrib non-free

deb-src http://mirrors.cloud.tencent.com/kali/ kali-rolling main contrib non-free

image.png

4、还需要添加数字签名和证书

wget -q -o - https://archive.kali.org/archive-key.asc 
apt-key add archive-key.asc 

5、就可以更新apt目录啦

apt update

6、更新完后提示,需要 apt list --upgradable

apt list --upgradable

7、这里不是很推荐更新upgrade,这样容易破坏系统原有的兼容性

8、接下来就可以安装工具啦

apt install sqlmap

image.png

9、ok成功安装

image.png

上一篇 下一篇